Back to overview
Degraded

Desktop Application Services, Mobile web services, and 1 other service are down

Mar 05 at 11:13am GMT
Affected services
Desktop Application Services
Mobile web services
Legacy Services

Resolved
Mar 05 at 05:08pm GMT

Legacy Services recovered.

Updated
Mar 05 at 05:03pm GMT

Legacy Services is degraded.

Updated
Mar 05 at 02:14pm GMT

Legacy Services recovered.

Updated
Mar 05 at 02:09pm GMT

Legacy Services is degraded.

Updated
Mar 05 at 11:18am GMT

Desktop Application Services and Mobile web services recovered.

Created
Mar 05 at 11:13am GMT

Desktop Application Services and Mobile web services are degraded.