Back to overview
Degraded

Desktop Application Services and Mobile web services are down

Feb 13 at 07:10pm GMT
Affected services
Desktop Application Services
Mobile web services

Resolved
Feb 13 at 11:45pm GMT

Desktop Application Services and Mobile web services recovered.

Updated
Feb 13 at 11:34pm GMT

Desktop Application Services and Mobile web services are degraded.

Updated
Feb 13 at 07:21pm GMT

Desktop Application Services and Mobile web services recovered.

Created
Feb 13 at 07:10pm GMT

Desktop Application Services and Mobile web services are degraded.