Back to overview
Degraded

Desktop Application Services, Mobile web services, and 1 other service are down

Nov 03 at 06:32am GMT
Affected services
Desktop Application Services
Mobile web services
Legacy Services

Resolved
Nov 03 at 03:28pm GMT

Desktop Application Services and Mobile web services recovered.

Updated
Nov 03 at 03:22pm GMT

Desktop Application Services and Mobile web services are degraded.

Updated
Nov 03 at 06:37am GMT

Legacy Services recovered.

Created
Nov 03 at 06:32am GMT

Legacy Services is degraded.