Desktop Application Services and Mobile web services are down
Resolved
Oct 3, 2025 at 2:10pm UTC
Desktop Application Services and Mobile web services recovered.
Affected services
Updated
Oct 3, 2025 at 1:59pm UTC
Desktop Application Services and Mobile web services are degraded.
Affected services
Updated
Oct 3, 2025 at 1:10pm UTC
Desktop Application Services and Mobile web services recovered.
Affected services
Updated
Oct 3, 2025 at 1:01pm UTC
Desktop Application Services and Mobile web services are degraded.
Affected services
Updated
Oct 3, 2025 at 10:21am UTC
Desktop Application Services and Mobile web services recovered.
Affected services
Created
Oct 3, 2025 at 10:13am UTC
Desktop Application Services and Mobile web services are degraded.
Affected services