Back to overview
Degraded

Desktop Application Services and Mobile web services are down

Sep 26 at 10:46am BST
Affected services
Desktop Application Services
Mobile web services

Resolved
Sep 26 at 10:55am BST

Desktop Application Services and Mobile web services recovered.

Created
Sep 26 at 10:46am BST

Desktop Application Services and Mobile web services are degraded.