Back to overview
Degraded

Desktop Application Services and Mobile web services are down

Sep 19 at 03:05am BST
Affected services
Desktop Application Services
Mobile web services

Resolved
Sep 19 at 02:52pm BST

Desktop Application Services and Mobile web services recovered.

Updated
Sep 19 at 02:47pm BST

Desktop Application Services and Mobile web services are degraded.

Updated
Sep 19 at 02:00pm BST

Desktop Application Services and Mobile web services recovered.

Updated
Sep 19 at 01:52pm BST

Desktop Application Services and Mobile web services are degraded.

Updated
Sep 19 at 03:23am BST

Desktop Application Services and Mobile web services recovered.

Created
Sep 19 at 03:05am BST

Desktop Application Services and Mobile web services are degraded.